Дмитрий

Можно ли обновлять веб-сервер Nginx из стороннего репозитория и будет ли нормально работать панель ispmanager 6?

Здравствуйте,

Подскажите, можно ли подключить сторонний репозиторий - официальный репозиторий Nginx и обновить на новую версию веб-сервер до более или менее современной версии, при этом не навредит ли это текущей конфигурации и дальнейшей работы панели управления сервером с не стандартной версией Nginx, то есть которая не из стандартного репозитория Ubuntu и более свежая.

Заранее спасибо за ответы!

05.02.2024 21:55

IgorG

Мы не рекомендуем подключать и использовать сторонние репозитории на сервере с ispmanager. Последствия этого могут быть непредсказуемыми, поскольку мы не можем протестировать работу панели со всем множеством подключаемых сторонних репозиториев. Если вы решаетесь на это, то вы делаете это на свой страх и риск. Что касается конкретно nginx, то различные аспекты могут отличаться в версиях из официального репозитория nginx и версии из официального репозитория вашей операционной системы - например пути, конфигурации, набор модулей и так далее. Все это может привести к некорректной работе панели.

07.02.2024 02:23

IgorG
Мы не рекомендуем подключать и использовать сторонние репозитории на сервере с ispmanager. Последствия этого могут быть непредсказуемыми, поскольку мы не можем протестировать работу панели со всем множеством подключаемых сторонних репозиториев. Если вы решаетесь на это, то вы делаете это на свой страх и риск. Что касается конкретно nginx, то различные аспекты могут отличаться в версиях из официального репозитория nginx и версии из официального репозитория вашей операционной системы - например пути, конфигурации, набор модулей и так далее. Все это может привести к некорректной работе панели.
Дмитрий

А как же быть с точки зрения уязвимостей и безопасности в связи со старой версией Nginx, если из стандартного репозитория Ubuntu она больше никогда не обновится до более новой версии, а подключать официальный репозиторий Nginx и обновлять версию веб-сервера до более новой опасно т.к. это может привести к некорректной работе панели?

07.02.2024 13:10

IgorG

Вендоры операционных систем выпускают обновления безопасности для своих пакетов даже после объявления EOL для операционной системы. Это стандартная практика. В конце концов версии OC уходят в прошлое и перестают поддерживаться вендором. Предполагается, что пользователь должен смигрировать на новую, полностью поддерживаемую и обновляемую версию операционной системы.

08.02.2024 02:18

IgorG

Вообще, у нас в планах поставлять собственную сборку nginx для всех осей. Она будет регулярно нами обновляться. Работаем над этим. Когда это случится пока сказать не могу.

09.02.2024 07:17