ispmanager 6

/
/
Панель недоступна после смены IP-адреса сервера

Панель недоступна после смены IP-адреса сервера

Симптомы

После смены IP-адреса сервера, панель недоступна ни по новому, ни по старому IP-адресу.

Причины

Веб-сервер панели настроен на прослушивание старого IP-адреса, который уже отсутствует на сервере.

Решение

В случае, если IP-адрес сервера был изменен без предварительной подготовки панели, потребуется внести изменения вручную.

Поскольку смена адреса была выполнена без предварительной подготовки, необходимо заменить IP-адрес во множестве конфигурационных файлов и настроек ПО.

Исправление IP-адреса веб-сервера панели

  1. Узнайте старый IP-адрес для встроенного веб-сервера панели с помощью команды:
    grep ip /usr/local/mgr5/etc/ihttpd.conf | grep "^[^#*]"
  2. Замените старый IP-адрес на новый, выполнив команду:
    sed -i "s/CТАРЫЙ_IP-АДРЕС/НОВЫЙ-АДРЕС/g" /usr/local/mgr5/etc/ihttpd.conf
  3. Перезагрузите встроенный веб-сервер:
    systemctl restart ihttpd

Убедитесь, что служба веб-сервера успешно запустилась, увидев строку «Active: active (running)» в выводе команды:

После этого веб-интерфейс панели станет доступен.

Исправление IP-адресов виртуальных хостов Nginx

  1. Замените предыдущий IP-адрес на текущий для всех хостов Nginx, выполнив команду:
    sed -i "s/CТАРЫЙ_IP-АДРЕС/НОВЫЙ-АДРЕС/g" /etc/nginx/vhosts/*/*
  2. Проверьте прочие конфигурационные файлы Nginx на наличие старого IP-адреса:
    grep -r CТАРЫЙ_IP-АДРЕС /etc/nginx | grep "^[^#*]"
  3. Замените старый IP-адрес на новый во всех конфигурационных файлах, что были получены в выводе на предыдущем этапе:
    sed -i "s/CТАРЫЙ_IP-АДРЕС/НОВЫЙ-АДРЕС/g" <путь-до-файла>
  4. Перезапустите веб-сервер Nginx:
    systemctl restart nginx

Убедитесь, что служба веб-сервера успешно запустилась, увидев строку «Active: active (running)» в выводе команды:

Исправление IP-адресов виртуальных хостов Apache

  1. Замените предыдущий IP-адрес на текущий для всех хостов Apache, выполнив команду:
    sed -i "s/CТАРЫЙ_IP-АДРЕС/НОВЫЙ-АДРЕС/g" /etc/apache2/vhosts/*/*
  2. Проверьте прочие конфигурационные файлы Apache на наличие старого IP-адреса:
    grep -r CТАРЫЙ_IP-АДРЕС /etc/apache2 | grep "^[^#*]"
  3. Замените старый IP-адрес на новый во всех конфигурационных файлах, что были получены в выводе на предыдущем этапе:
    sed -i "s/CТАРЫЙ_IP-АДРЕС/НОВЫЙ-АДРЕС/g" <путь-до-файла>
  4. Перезапустите веб-сервер Apache:
    systemctl restart apache2

Убедитесь, что служба веб-сервера успешно запустилась, увидев строку «Active: active (running)» в выводе команды:

Обратите внимание!

В RHEL-based системах директория и служба веб-сервера Apache носит название «httpd»

Исправление IP-адреса в прочих файлах

Если установлен почтовый сервер, замените IP-адрес в конфигурационном файле Exim:

Для RedHat-based операционных систем, путь до конфигурационного файла Exim отличается - /etc/exim/exim.conf.

Если нативный сервер баз данных ранее использовал старый IP-адрес для работы (не localhost127.0.0.1 или 0.0.0.0), потребуется заменить IP-адрес в его конфигурационных файлах.

Также потребуется пересоздать альтернативные СУБД, созданные средствами панели - базы данных будут сохранены.

Обратите внимание!

Перед пересозданием альтернативных СУБД рекомендуется сделать копии их данных, которые находятся по пути /var/lib/ и /var/ispmysql.

Чтобы проверить наличие старого IP-адреса в конфигурационных файла MySQL, выполните команду:

Замените старый IP-адрес на новый в каждом файле, который был указан в выводе предыдущей команды:

Действия в панели

Измените IP-адрес для всех сущностей панели в следующих разделах:

  • Доменов в разделе Управление DNS;
  • Сайтов в разделе Сайты;
  • Серверов баз данных в разделе Базы данных - Серверы БД, если был включен удаленный доступ к ним;
  • Почтовых доменов в разделе Почта - Почтовые домены.